手机版 官方微博
官方微信
扫描关注:理想财富微信公众号
高频彩平台App
扫描下载高频彩平台App
RSS

请老师帮助为通达信《大资金顶底》副图指标编写个选股公式

[通达信]
设置
3551 2 青山778899 Lv.2 发表于 · 2020-5-12 14:24 举报 只看楼主 复制 倒序浏览 |
跳转到指定楼层
恳请老师为通达信《大资金顶底》副图指标写一个选股公式

副图指标公式如下:

大资金顶底

VAR1:=5;
VAR2:=10;
VAR3:=REF(CLOSE,1);
VAR4:=(2*CLOSE+HIGH+LOW)/4;
VAR5:=MA(VAR4,3)>REF(MA(VAR4,3),1);
安全线:2,POINTDOT,COLORRED,LINETHICK4;
VAR6:=(CLOSE-LLV(LOW,7))/(HHV(HIGH,7)-LLV(LOW,7))*10;
K:MA(3*SMA(VAR6,6,1)-2*SMA(SMA(VAR6,5,1),5,1),3),COLORF00FF0;
D:MA(K,3),COLORBLUE;
J:3*K-2*D,COLORF00FF0;
DRAWBAND(K,RGB(155,50,50),D,RGB(0,100,50));
VAR7:=CLOSE-REF(CLOSE,1);
VAR8:=100*EMA(EMA(VAR7,6),6)/EMA(EMA(ABS(VAR7),6),6);
VAR9:=EMA(CLOSE,5);
VAR10:=EMA(CLOSE,13);
VAR11:=DRAWLINE(LOW=LLV(LOW,BARSLAST(CROSS(VAR10,VAR9))+1),LLV(LOW,BARSLAST(CROSS(VAR10,VAR9))+1),HIGH=HHV(HIGH,BARSLAST(CROSS(VAR9,VAR10))+1),HHV(HIGH,BARSLAST(CROSS(VAR9,VAR10))+1),0);
VAR12:=DRAWLINE(HIGH=HHV(HIGH,BARSLAST(CROSS(VAR9,VAR10))+1),HHV(HIGH,BARSLAST(CROSS(VAR9,VAR10))+1),LOW=LLV(LOW,BARSLAST(CROSS(VAR10,VAR9))+1),LLV(LOW,BARSLAST(CROSS(VAR10,VAR9))+1),0);
BT:LLV(VAR8,2)=LLV(VAR8,7) AND COUNT(VAR8<0,2) AND CROSS(VAR8,MA(VAR8,2)) AND REF(VAR12,1)<REF(VAR12,2) AND VAR11>REF(VAR12,1);
底线:0,COLORMAGENTA;
顶线:10,COLORBLUE;
STICKLINE(VAR11,0,0.2,3,0),COLORRED;
STICKLINE(VAR12,0,0.2,3,0),COLORGREEN;
STICKLINE(BT,0,3,2,0),COLOR000088;
STICKLINE(BT,0,3,1,0),COLOR0000CC;
STICKLINE(BT,0,3,0.22,0),COLORRED;
DRAWTEXT(BT,3,57),COLORRED;
TJ1:REF(VAR12,1)<REF(VAR12,2) AND VAR11>REF(VAR12,1) AND CLOSE<HHV(HIGH,21)*0.82;
STICKLINE(TJ1,0,2,3,0),COLOR880088;
STICKLINE(TJ1,0,2,1.5,0),COLORAA00AA;
STICKLINE(TJ1,0,2,0.8,0),COLORCC00CC;
STICKLINE(TJ1,0,2,0.2,0),COLORMAGENTA;
DRAWTEXT(TJ1,2,58),COLORMAGENTA;
VAR13:=HHV(HIGH,55);
VAR14:=LLV(LOW,55);
VAR15:=VAR13*VAR14;
VAR16:=SQRT(VAR15);
TJ2:REF(VAR12,1)<REF(VAR12,2) AND VAR11>REF(VAR12,1) AND CLOSE<VAR16;
STICKLINE(TJ2,0,1,5,0),COLOR008888;
STICKLINE(TJ2,0,1,2,0),COLOR00AAAA;
STICKLINE(TJ2,0,1,1,0),COLOR00CCCC;
STICKLINE(TJ2,0,1,0.2,0),COLORYELLOW;
DRAWTEXT(TJ2,1,59),COLORYELLOW;
VAR17:=REF(VAR11,1)>REF(VAR11,2) AND VAR12<REF(VAR11,1);
STICKLINE(VAR17,10,9,5,0),COLOR008800;
STICKLINE(VAR17,10,9,2,0),COLOR00AA00;
STICKLINE(VAR17,10,9,1,0),COLOR00CC00;
STICKLINE(VAR17,10,9,0.2,0),COLORGREEN;
DRAWTEXT(VAR17,9,4),COLORGREEN;
DIFF:EMA(DCLOSE,12)-EMA(DCLOSE,26);
DEA:EMA(DIFF,9),COLORCYAN;
VAR18:=BARSLAST(REF(CROSS(DIFF,DEA),1));
底背离:REF(CLOSE,VAR18+1)>CLOSE AND DIFF>REF(DIFF,VAR18+1) AND CROSS(DIFF,DEA);
DRAWTEXT(底背离,(-0.6),60),COLORWHITE;
VAR19:=BARSLAST(REF(CROSS(DEA,DIFF),1));
顶背离:REF(CLOSE,VAR19+1)<CLOSE AND REF(DIFF,VAR19+1)>DIFF AND CROSS(DEA,DIFF);
DRAWTEXT(顶背离,11,61),COLORWHITE;
买入:ZIG(3,5)>REF(ZIG(3,5),1) AND REF(ZIG(3,5),1)<=REF(ZIG(3,5),2) AND REF(ZIG(3,5),2)<=REF(ZIG(3,5),3),COLORRED;
卖出:ZIG(3,5)<REF(ZIG(3,5),1) AND REF(ZIG(3,5),1)>=REF(ZIG(3,5),2) AND REF(ZIG(3,5),2)>=REF(ZIG(3,5),3),COLORGREEN;


因为权限有限不能上图,所以只能描述: 当指标中出现《红三角买入》时做一个选股公式。在这里先谢过各位老师了!!!

相关股票

举报

扔鸡蛋(0) 回复

东方不帅168
Lv.2
发表于 2020-5-12 14:36 复制 2楼 只看该作者
VAR1:=5;
VAR2:=10;
VAR3:=REF(CLOSE,1);
VAR4:=(2*CLOSE+HIGH+LOW)/4;
VAR5:=MA(VAR4,3)>REF(MA(VAR4,3),1);
安全线:2,POINTDOT,COLORRED,LINETHICK4;
VAR6:=(CLOSE-LLV(LOW,7))/(HHV(HIGH,7)-LLV(LOW,7))*10;
K:MA(3*SMA(VAR6,6,1)-2*SMA(SMA(VAR6,5,1),5,1),3),COLORF00FF0;
D:MA(K,3),COLORBLUE;
J:3*K-2*D,COLORF00FF0;
DRAWBAND(K,RGB(155,50,50),D,RGB(0,100,50));
VAR7:=CLOSE-REF(CLOSE,1);
VAR8:=100*EMA(EMA(VAR7,6),6)/EMA(EMA(ABS(VAR7),6),6);
VAR9:=EMA(CLOSE,5);
VAR10:=EMA(CLOSE,13);
VAR11:=DRAWLINE(LOW=LLV(LOW,BARSLAST(CROSS(VAR10,VAR9))+1),LLV(LOW,BARSLAST(CROSS(VAR10,VAR9))+1),HIGH=HHV(HIGH,BARSLAST(CROSS(VAR9,VAR10))+1),HHV(HIGH,BARSLAST(CROSS(VAR9,VAR10))+1),0);
VAR12:=DRAWLINE(HIGH=HHV(HIGH,BARSLAST(CROSS(VAR9,VAR10))+1),HHV(HIGH,BARSLAST(CROSS(VAR9,VAR10))+1),LOW=LLV(LOW,BARSLAST(CROSS(VAR10,VAR9))+1),LLV(LOW,BARSLAST(CROSS(VAR10,VAR9))+1),0);
BT:LLV(VAR8,2)=LLV(VAR8,7) AND COUNT(VAR8<0,2) AND CROSS(VAR8,MA(VAR8,2)) AND REF(VAR12,1)<REF(VAR12,2) AND VAR11>REF(VAR12,1);
底线:0,COLORMAGENTA;
顶线:10,COLORBLUE;
STICKLINE(VAR11,0,0.2,3,0),COLORRED;
STICKLINE(VAR12,0,0.2,3,0),COLORGREEN;
STICKLINE(BT,0,3,2,0),COLOR000088;
STICKLINE(BT,0,3,1,0),COLOR0000CC;
STICKLINE(BT,0,3,0.22,0),COLORRED;
DRAWTEXT(BT,3,57),COLORRED;
TJ1:REF(VAR12,1)<REF(VAR12,2) AND VAR11>REF(VAR12,1) AND CLOSE<HHV(HIGH,21)*0.82;
STICKLINE(TJ1,0,2,3,0),COLOR880088;
STICKLINE(TJ1,0,2,1.5,0),COLORAA00AA;
STICKLINE(TJ1,0,2,0.8,0),COLORCC00CC;
STICKLINE(TJ1,0,2,0.2,0),COLORMAGENTA;
DRAWTEXT(TJ1,2,58),COLORMAGENTA;
VAR13:=HHV(HIGH,55);
VAR14:=LLV(LOW,55);
VAR15:=VAR13*VAR14;
VAR16:=SQRT(VAR15);
TJ2:REF(VAR12,1)<REF(VAR12,2) AND VAR11>REF(VAR12,1) AND CLOSE<VAR16;
STICKLINE(TJ2,0,1,5,0),COLOR008888;
STICKLINE(TJ2,0,1,2,0),COLOR00AAAA;
STICKLINE(TJ2,0,1,1,0),COLOR00CCCC;
STICKLINE(TJ2,0,1,0.2,0),COLORYELLOW;
DRAWTEXT(TJ2,1,59),COLORYELLOW;
VAR17:=REF(VAR11,1)>REF(VAR11,2) AND VAR12<REF(VAR11,1);
STICKLINE(VAR17,10,9,5,0),COLOR008800;
STICKLINE(VAR17,10,9,2,0),COLOR00AA00;
STICKLINE(VAR17,10,9,1,0),COLOR00CC00;
STICKLINE(VAR17,10,9,0.2,0),COLORGREEN;
DRAWTEXT(VAR17,9,4),COLORGREEN;
DIFF:EMA(DCLOSE,12)-EMA(DCLOSE,26);
DEA:EMA(DIFF,9),COLORCYAN;
VAR18:=BARSLAST(REF(CROSS(DIFF,DEA),1));
底背离:REF(CLOSE,VAR18+1)>CLOSE AND DIFF>REF(DIFF,VAR18+1) AND CROSS(DIFF,DEA);
DRAWTEXT(底背离,(-0.6),60),COLORWHITE;
VAR19:=BARSLAST(REF(CROSS(DEA,DIFF),1));
顶背离:REF(CLOSE,VAR19+1)<CLOSE AND REF(DIFF,VAR19+1)>DIFF AND CROSS(DEA,DIFF);
DRAWTEXT(顶背离,11,61),COLORWHITE;
买入:ZIG(3,5)>REF(ZIG(3,5),1) AND REF(ZIG(3,5),1)<=REF(ZIG(3,5),2) AND REF(ZIG(3,5),2)<=REF(ZIG(3,5),3);

这种带未来函数的没有任何意义

举报

点亮(1) 扔鸡蛋(0) 回复

青山778899
Lv.2
发表于 2020-5-12 15:16 复制 3楼 只看该作者
东方不帅168 发表于 2020-5-12 14:36
VAR1:=5;
VAR2:=10;
VAR3:=REF(CLOSE,1);

谢谢提醒,作为一种参考也是有一定意义的。

举报

点亮(0) 扔鸡蛋(0) 回复

您需要登录后才可以回帖 免费注册登录

本版积分规则

论坛问题
微信扫一扫,添加好友咨询
驿站问题
微信扫一扫,添加好友咨询
广告投放
微信扫一扫,添加好友咨询
回顶部 到页底
快速回复 返回顶部 返回列表